仓位增减(通达信公式 源码 K线图)

qianglongwang
69918
文章
3
评论
2019年7月11日13:12:23 评论 289 1484字阅读4分37秒

指标代码及说明:

上线:=SMA(C,6.5,1); 下线:=SMA(C,13.5,1); 上线1:=SMA(C,3,1); 下线1:=SMA(C,10,1); STICKLINE(上线>下线 , 上线,下线 ,2.5, 0),COLORRED,LINETHICK2; STICKLINE(下线>上线,上线,下线,2.5,0),LINETHICK2,COLORBLUE; DRAWTEXT( CROSS(上线,下线),LOW *0.96,'全仓' ),COLORRED; DRAWTEXT(CROSS(下线1,上线1),H*1.02,'清仓'),COLORBLUE; BBI:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4; UPR:=BBI+3*STD(BBI,13); DWN:=BBI-3*STD(BBI,13); 安全线:MA(CLOSE,60); LC:=REF(CLOSE,1); RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100; DRAWTEXT( CROSS(82,RSI) , HIGH*1.02,'减仓') ,LINETHICK2,COLORBLUE;

VARA:=(CLOSE-REF(OPEN,29))/REF(OPEN,29)*100; VARB:=EMA(0.667*REF(VARA,1)+0.333*VARA,5); DRAWTEXT(IF(VOL>=1.3*MA(VOL,5) AND COUNT(VARA>=VARB AND VARA<-17,3) AND REF(LOW,1)=LLV(LOW,120),1,0),LOW,'加仓'),COLORRED;

A7:=(2*C+H+L)/4; 操作:=MA(A7,5); 操作1:=MA(A7,5)*1.03; 操作2:=MA(A7,5)*0.97; VAR1:=LLV(A7,21); VAR2:=HHV(A7,21); SK:=EMA((A7-VAR1)/(VAR2-VAR1)*100,7); SD:=EMA(0.667*REF(SK,1)+0.333*SK,5); DRAWTEXT(IF(COUNT(CLOSE<REF(CLOSE,1),8)/8>6/10 AND VOL>=1.5*MA(VOL,5) AND COUNT(SK>=SD,3) AND REF(LOW,1)=LLV(LOW,120),1,0),LOW*0.98,'买进') ; DRAWTEXT(IF(COUNT(CLOSE<REF(CLOSE,1),13)/13>6/10 AND COUNT(SK>SD,6) AND REF(LOW,5)=LLV(LOW,120) AND REF(CLOSE>=OPEN,4) AND REF(CLOSE>OPEN,3) AND REF(CLOSE>OPEN,2) AND REF(OPEN>CLOSE,1) AND OPEN>REF(CLOSE,1),1,0),LOW*0.98,'买进') ; D:=MA(CLOSE,80)-MA(CLOSE,10)/3; DRAWTEXT(IF(CLOSE<D AND VOL/240>MA(VOL,5)/240 AND CLOSE>REF(CLOSE,1)*1.08 AND CLOSE<MA(CLOSE,13)*1.3,1,0),LOW*0.98,'抄底');

代写炒股公式或微信:chaogugongshi 进行 有偿 编写!
  • 炒股公式网声明:文中提供的信息仅代表作者个人观点。不保证该信息(包括但不限于文字、数据及图表)全部或者部分内容的准确性、真实性、完整性、有效性、及时性、原创性等,若有侵权,请第一时间告知删除。仅供投资者参考,并不构成投资建议。投资者据此操作,风险自担。版权投诉邮箱:vfffq761@foxmail.com
匿名

发表评论

匿名网友 填写信息

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: